Forum    Members    Search    FAQ

Board index » Erfworld Things » Gems and Mine4Erf




Post new topic  Reply to topic  [ 3 posts ] 
 
Author Message
 Post Posted: Mon Apr 16, 2018 10:14 am 
Here for the 10th Anniversary Has collected at least one unit
Offline
Joined: Wed Dec 07, 2016 1:24 pm
Posts: 8
So, I decided to give Mine4 Erf another crack considering the recent update to the program (though for some reason I got 0.4.3-beta instead of 0.4.2), and I saw this batch of errors in the output.

Code:
[10:05:20] Error -11: Building Program (clBuildProgram)
[10:05:20] "C:\Users\[Yana]\AppData\Local\Temp\OCLA20F.tmp.cl", line 93: error
:
          function "amd_bitalign" declared implicitly
      offset = amd_bitalign(offset, offset, 29U);
               ^
"C:\Users\[Yana]\AppData\Local\Temp\OCLA20F.tmp.cl", line 112: error:
          function "amd_bitalign" declared implicitly
      offset = amd_bitalign(offset, offset, 29U);
               ^
"C:\Users\[Yana]\AppData\Local\Temp\OCLA20F.tmp.cl", line 140: error:
          function "amd_bitalign" declared implicitly
      offset = amd_bitalign(offset, offset, 29U);
               ^
"C:\Users\[Yana]\AppData\Local\Temp\OCLA20F.tmp.cl", line 159: error:
          function "amd_bitalign" declared implicitly
      offset = amd_bitalign(offset, offset, 29U);
               ^
"C:\Users\[Yana]\AppData\Local\Temp\OCLA20F.tmp.cl", line 176: error:
          function "amd_bitalign" declared implicitly
          roffset = 32U - amd_bitalign(offset, offset, 29U);
                          ^
5 errors detected in the compilation of "C:\Users\NODMIL~1\AppData\Local\Temp\OC
LA20F.tmp.cl".

Frontend phase failed compilation.


I'm not sure exactly what that's supposed to mean, but it looks to me like something got broken in the 0.4.3-beta version of Mine4Erf.

(I've attached a screenshot of the output, in case that helps any.)


Attachments:
mine4erf 043 compilation error.png
mine4erf 043 compilation error.png [ 42.09 KiB | Viewed 653 times ]
  • Tip this post

    Make Anonymous
  • Top 
       
     Post Posted: Mon Apr 16, 2018 11:02 am 
    User avatar
    This user posted the comment of the month Here for the 10th Anniversary Has collected at least one unit Mined 4 Erf This user got funny with a rodent This user is a Tool! Shiny Red Star Won Mine4erf for the Gobwins For when you need it most
    Offline
    Joined: Thu Dec 05, 2013 9:33 am
    Posts: 1284
    No such problems for me. Been using the 0.4.3-beta for weeks now.

    I notice your graphics card is showing up as a "Devastator". That's an AMD Radeon HD 6/7/8000 series integrated graphics adapter. Those have consistently proven problematic for mining. The best I can tell something about their OpenCL 1.2 implementation is wrong... what you are seeing is errors from that, most likely.

    _________________
    Everyone's Favorite Naughtymancer,
    JadedDragoon

    Fear the would-be hero. For against the pangs of conscience, there is no more effective anesthesia than a righteous cause. And no one sees themselves as the villain, especially the villain.

  • Tip this post

    Make Anonymous
  • Top 
       
     Post Posted: Wed May 16, 2018 6:11 am 
    Site Admin
    User avatar
    Shiny Red Star This user is a member of Team Erfworld Pin-up Calendar and New Art Team Supporter IRC Quote of the Moment Here for the 10th Anniversary Has collected at least one unit Erfworld Bicycle® Playing Cards supporter Mined 4 Erf Won Mine4erf for the Gobwins Won Mine4erf for the Marbits
    Offline
    Joined: Tue Sep 22, 2009 2:10 am
    Posts: 232
    Unfortunately yes, you have an integrated graphics setup and it can't run mine4erf. The new 0.5 line of miners will show a clearer error message if it detects a "Devastator" card, reporting that it has integrated graphics which can't work, but unfortunately I don't have a fix that would enable it to actually run.

    _________________
    Prediction Booker, Fermi Estimator, Utopian, Knight of Light, Wizard Incantatrix. Also known as Namegduf.

    "Everything Is Complicated, Let's Try Anyway."

    Site Architect, Developer, Administrator, Moderator, Web Team

  • Tip this post

    Make Anonymous
  • Top 
       
    Display posts from previous:  Sort by  
     
    Post new topic  Reply to topic  [ 3 posts ] 

    Board index » Erfworld Things » Gems and Mine4Erf


    Who is online

    Users browsing this forum: No registered users and 1 guest

     
     

     
    You cannot post new topics in this forum
    You cannot reply to topics in this forum
    You cannot edit your posts in this forum
    You cannot delete your posts in this forum
    You cannot post attachments in this forum

    Search for:
    Jump to: